Why do I need a Compatibility Addon?

Like many other WooCommerce plugins – our core QuickBooks Sync plugin only supports core WooCommerce features. While this is for many reasons – the foremost reason is to ensure we’re able to consistently update and improve on our integration features based on a stable codebase: the woocommerce core.

However, as many store owners are aware – sometimes additional plugins are required in order to make WooCommerce function to fit your business workflow and processes. Since it is impossible for us to anticipate and pre-build compatibility for any type of third-party plugin, we have split off compatibility with third-party plugins into a separate WooCommerce plugin: our Compatibility Addon plugin.

There are a few reasons that we support compatibility through a separate plugin from our core QuickBooks Sync plugin – but mainly this is to ensure a stable development cycle for our core plugin, and make it much more flexible and efficient to push updates out to our compatibility plugin when they are required. 

 

Why is the compatibility addon an additional cost?
We charge an additional yearly fee for our compatibility addons for two reasons:

  1. Ongoing development resources to develop/ensure ongoing compatibility as our core sync plugin, the WooCommerce plugin, and the third party plugins are upgraded and evolve.
  2. Support and documentation needed to ensure a smooth experience for our end users.

 

What do I do if I’m using a third-party plugin you don’t currently support?
Contact us to share the details about your custom plugin, and we can discuss the possibility of customizing a compatibility for you. All custom compatibility work is charged at a discounted $59/hr rate for our clients – and most custom compatibility ranges between 2-6 development hours.

 

How do I add a compatibility addon to my license?
Simply visit your license in your account with us, and click the Add Compatibility Add-on button in the lower right to choose and select an addon. 

 

 

Which third-party plugins have compatibility support?
To see a complete list of our available compatibility addons, visit our Summary page here.

Updated on May 3, 2018

Was this article helpful?